Back to overview
Downtime

Core Services, Mail Services, and 2 other services are down

Jan 20 at 12:07am UTC
Affected services
Core Services
Mail Services
SaneChoice Email (POP3)
PLESK Hosting Portal

Resolved
Jan 20 at 11:02am UTC

Mail Services and SaneChoice Email (POP3) recovered.

Updated
Jan 20 at 10:49am UTC

Core Services and PLESK Hosting Portal recovered.

Created
Jan 20 at 12:07am UTC

Core Services, Mail Services, SaneChoice Email (POP3), and 1 other resource went down.